[swift-evolution] Make non-void functions @warn_unused_result by default

Sean Heber sean at fifthace.com
Wed Feb 24 14:51:20 CST 2016



> On Feb 24, 2016, at 2:37 PM, Haravikk via swift-evolution <swift-evolution at swift.org> wrote:
>> On 24 Feb 2016, at 19:27, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
>> on Wed Feb 24 2016, Chris Lattner <swift-evolution at swift.org> wrote:
>>>> On Feb 24, 2016, at 7:13 AM, Janosch Hildebrand via swift-evolution <swift-evolution at swift.org> wrote:
>>>> Erica's proposal about "Modernizing Attribute Case and Attribute Argument Naming" made me remember this discussion.
>>>> I don't think a proposal was ever submitted? If no one else is
>>>> working on a proposal already I would offer myself up for writing
>>>> this up.
>>> I don’t recall a real proposal, it would be great for you to drive this.
>> Yes, please!  I *really* want this change.
> Same!
> The only thing that needs to be considered is what to name the replacement attribute (for methods where the return value isn’t important). I’m thinking @optionalReturn or @ignoreUnusedResult or such.
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution

More information about the swift-evolution mailing list