[swift-evolution] Rename 'guard' to 'ensure'

Haravikk swift-evolution at haravikk.me
Tue Feb 23 13:44:49 CST 2016

I’m not strictly against the proposal, but I don’t think that renaming to ensure adds anything.

guard is essentially a neat feature for programming defensively, so guard to me is stronger fit thematically in that sense.

> On 19 Feb 2016, at 21:49, John Flanagan via swift-evolution <swift-evolution at swift.org> wrote:
> The functionality of ‘guard’ is great and this proposal has nothing to do with changing that. The only suggestion is that the word ‘ensure’ would better communicate what a ‘guard’ statement does to those encountering it for the first time and would make code more readable in general.
> Example:
> ensure foo != nil else {
>    return;
> }
> -John
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160223/f3974259/attachment.html>

More information about the swift-evolution mailing list