[swift-evolution] Rename 'guard' to 'ensure'

John Flanagan john at jflan.com
Mon Feb 22 18:22:36 CST 2016

I'm not sure that "sugar" is the right word, but I will give you that "guard" is probably too well established to be usurped by ensure™ just for the sake of grammar. 
From: Shawn Erickson <shawnce at gmail.com>
Sent: Monday, February 22, 2016 11:07 AM
Subject: Re: [swift-evolution] Rename 'guard' to 'ensure'
To: John Flanagan <john at jflan.com>,  <swift-evolution at swift.org>

       Ensure(TM) ...has a little much sugar for my wants in a drink   
I get and like the suggestion from a grammar pov however guard is a little more forceful in terminology which aligns with the fact that you cannot proceed past the guard unless the condition is met. (I have a vision of a little guard standing at his guard post checking papers)   
         On Mon, Feb 22, 2016 at 9:01 AM John Flanagan via swift-evolution <    swift-evolution at swift.org> wrote:    
               The functionality of ‘guard’ is great and this proposal has nothing to do with changing that. The only suggestion is that the word ‘ensure’ would better communicate what a ‘guard’ statement does to those encountering it for the first time and would make code more readable in general.           
                ensure foo != nil else {                   return;                }                
                -John         _______________________________________________    
 swift-evolution mailing list    
     swift-evolution at swift.org    

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160223/353dc63d/attachment.html>

More information about the swift-evolution mailing list