[swift-evolution] ed/ing, InPlace, Set/SetAlgebra naming resolution

Dave Abrahams dabrahams at apple.com
Thu Feb 11 19:33:32 CST 2016

on Thu Feb 11 2016, Greg Parker <swift-evolution at swift.org> wrote:

>> On Feb 11, 2016, at 3:54 PM, Xiaodi Wu via swift-evolution <swift-evolution at swift.org> wrote:
>> This is an interesting bit of historical perspective. Dave--may I ask
>> a naive question?
>> The proposal as shown is extensive. Would it be within reach/easier to
>> pitch/feasible to implement a narrower set of changes to facilitate
>> naming convention only? Namely: alter Swift syntax to allow function
>> names to begin with "=" and adopt naming conventions that
>> mutating/non-mutating pairs of functions are named
>> =frobnicate()/frobnicate()? That would, it seems, go a long way.
> That would not be a small change. The strict separation between
> operator characters and non-operator characters is deeply embedded
> into Swift's grammar and compiler.

Well, considering that we have a (reverted) change in the Git tree that
implements the whole feature as specified, it might not be *that* hard,
unless the whole lexing/parsing system has been completely rebuilt since


More information about the swift-evolution mailing list