[swift-evolution] [Accepted] SE-0028 Modernizing Swift's Debugging Identifiers (__LINE__, etc)
clattner at apple.com
Thu Feb 4 11:29:28 CST 2016
> On Feb 4, 2016, at 7:03 AM, Erica Sadun via swift-evolution <swift-evolution at swift.org> wrote:
>> On Feb 4, 2016, at 1:24 AM, Dave Abrahams via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
>> I'm afraid we'll ultimately need to solve this some other way than by
>> choosing a different name. We're eventually going to end up with
>> something meaning #sourceLocation (modulo capitalization) and that's
>> obviously (IMO) going to be the right name for both entities.
I don’t agree with you Dave, these are certainly related, but also very different operations.
> On the "Renaming #line, the line control statement" thread, Brent Royal-Gordon suggests introducing a different grammar,
> #reset line=50, file="foo.swift"
> that could be applied to all the newly renamed items, not just #line. Is this feasible?
Yep, something with its own unique grammar would be fine, particularly for the directive form. I’ll comment in the other thread.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution