[swift-evolution] Proposal: Remove implicit tuple splat behavior from function applications

Kevin Ballard kevin at sb.org
Sun Jan 31 19:00:18 CST 2016


+1 in general, though I do wonder how this change will affect generic code. For example, if I have a function that returns a tuple, and another function that takes an argument list matching the same tuple type, can I still use generic functions like map() to call the second function with the tuple from the first? I'm hoping the answer is "yes", because the type of a function doesn't distinguish between functions that take multiple arguments vs functions that take a single argument of tuple type and so passing functions around as first-class values should be fine. Although I imagine this change will still prevent me from writing a closure like { funcOfTwoArgs($0) } which is unfortunate, but would be solved by a subsequent proposal to add an explicit splat operator.

-Kevin Ballard

> On Jan 26, 2016, at 10:23 PM, Chris Lattner via swift-evolution <swift-evolution at swift.org> wrote:
> 
> For discussion: comments appreciated!
> 
> 
> 
> 
> Remove implicit tuple splat behavior from function applications
> Proposal: SE-TBD
> Author(s): Chris Lattner
> Status: Awaiting review
> Review manager: TBD
> Introduction
> 
> Function calls (which include several syntactic forms that apply an argument list to something of function type) currently have a dual nature in Swift.  Given something like:
> 
> 
> 	func foo(a : Int, b : Int) {}
> 
> 
> You can call it either with with the typical syntactic form that passes arguments to each of its parameters:
> 
> 
> 	foo(42, b : 17)
> 
> or you can take advantage of a little-known feature to pass an entire argument list as a single value (of tuple type):
> 
> 	let x = (1, b: 2)
> 	foo(x)
> 
> 
> This proposal recommends removing the later form, which I affectionately refer to as the “tuple splat” form.  This feature is purely a sugar feature, it does not provide any expressive ability beyond passing the parameters manually.
> 
> 
> Swift-evolution thread: TBD
> 
> Motivation
> 
> This behavior is cute, precedented in other functional languages, and has some advantages, but it also has several major disadvantages, which are all related to its syntactic form.
> 
> * A call to foo(x) looks like a call to an overloaded version of foo, both to the compiler and to the human who maintains the code.  This is extremely confusing if you don’t know the feature exists.
> * There are real ambiguities in the syntax, e.g. involving Any arguments and situations where you want to pass a tuple value as a single parameter.
> * The current implementation has a ton of implementation bugs - it doesn’t work reliably.
> * The current implementation adds complexity to the type checker, slowing it down and adding maintenance burden.
> * The current implementation doesn’t work the way we would want a tuple splat operation to work.  For example, arguably, you should be able to call foo with:
> 
> 	func bar() -> (Int, Int) { … }
> 	foo(bar())
> 
> … but this is not allowed, since tuple labels are required to line up.  You have to write:
> 
> 	func bar() -> (Int, b: Int)  { … }
> 	foo(bar())
> 
> 
> This makes this feature very difficult to use in practice, because you have to _’ize a lot of parameters (violating naming conventions), perform manual shuffling (defeating the sugar benefits of the feature), or add parameter labels to the result of functions (which leads to odd tying between callers and callees).
> 
> 
> The root problem here is that we use exactly the same syntax for both forms of function application.  If the two forms were differentiated (an option considered in “alternatives considered” below) then some of these problems would be defined away.
> 
> From a historical perspective, the tuple splat form of function application dates back to very early Swift design (probably introduced in 2010, but possibly 2011) where all function application was of a single value to a function type.  For a large number of reasons (including default arguments, variadic arguments, labels, etc) we have completely abandoned this model, but we never came back to reevaluating the tuple splat behavior.
> 
> If we didn’t already have this feature, we would not add it to Swift 3 (at least in its current form).
> 
> Proposed solution
> 
> The proposed solution is simple, we should just remove this feature from the Swift 3 compiler.  Ideally we would deprecate it in the Swift 2.2 compiler and remove it in Swift 3.  However, if there isn’t time to get the deprecation into Swift 2.2, the author believes it would be perfectly fine to just remove it in Swift 3 (with a fixit + migration help of course).
> 
> One of the interesting aspect of this feature is that some of the people we’ve spoken to are very fond of it.  However, when pressed, they admit that they are not actually using it widely in their code, or if they are using it, they are abusing naming conventions (distorting their code) in order to use it.  This doesn’t seem like a positive contribution - this seems like a “clever” feature, not a practical one.
> 
> Detailed design
> 
> The design is straight-forward.  In the Swift 3 time frame, we continue to parse and type check these expressions as we have so far, but produce an error + fixit hint when it is the tuple splat form.  The migrator would auto-apply the fixit hint as it does for other cases.
> 
> Impact on existing code
> 
> Any code that uses this feature will have to move to the traditional form.  In the case of the example above, this means rewriting the code from:
> 
> 	foo(x)
> 
> into a form like this:
> 
> 	foo(x.0, x.b)
> 
> In the case where “x” is a complex expression, a temporary variable will need to be introduced.  We believe that compiler fixits can handle the simple cases directly and that this extension is not widely used.
> 
> Alternatives considered
> 
> The major problem with this feature is that it was not well considered and implemented properly (owing to its very old age, it has just been kept limping along).  The alternative then is to actually design a proper feature to support this.  Since the implicitness and syntactic ambiguity with normal function application is the problem, the solution is to introduce an explicit syntactic form to represent this.  For example, something like this could address the problems we have:
> 
> 	foo(*x)    // NOT a serious syntax proposal
> 
> However, actually designing this feature would be a non-trivial effort not core to the Swift 3 mission:
> 
> * It is a pure-sugar feature, and therefore low priority.
> * We don’t have an obvious sigil to use.  “prefix-star” should be kept as unused for now in case we want to use it to refer to memory-related operations in the future.
> * Making the tuple splat operation great requires more than just fixing the syntactic ambiguities we have, it would require re-evaluating the semantics of the operation (e.g. in light of parameter labels, varargs and other features).
> 
> If there is serious interest in pursuing this as a concept, we should do it as a follow-on proposal to this one.  If a good design emerges, we can evaluate that design based on its merits.
> 
> 
> The final alternative is that we could leave the feature in the compiler.  However, that means living with its complexity “forever” or breaking code in the Swift 4 timeframe.  It would be preferable to tackle this breakage in the Swift 3 timeframe, since we know that migration will already be needed then.
> 
> -Chris
> 
> 
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160131/35d7be2b/attachment.html>


More information about the swift-evolution mailing list