[swift-evolution] Renaming "Build Configuration"

Kevin Ballard kevin at sb.org
Thu Jan 28 13:08:20 CST 2016

Renaming this seems like a good idea.

On Wed, Jan 27, 2016, at 05:18 PM, Jordan Rose via swift-evolution wrote:
> - "Custom Compilation Features" for all the user-defined options.
> - "marks a custom compilation feature as present" as the --help text
>   for -D.
> …but I'd be happy if someone comes up with something better. (And
> I'd like feedback on if any of these names are problematic in some
> other way.)

How about "Conditional Compilation Flags" for the user-defined options?
The term "flag" implies boolean, and also connotes the presence of the
flag as being the true value. The help text can then say "marks a
conditional compilation flag as true". The boolean nature of the flag
also makes the syntax `#if SomeFlag` make more sense, because we're used
to if conditions being boolean values.

-Kevin Ballard
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160128/d799235b/attachment.html>

More information about the swift-evolution mailing list