[swift-evolution] [Review] SE-0006 Apply API Guidelines to the Standard Library

Dave Abrahams dabrahams at apple.com
Wed Jan 27 02:48:29 CST 2016

on Tue Jan 26 2016, Guillaume Lessard <swift-evolution at swift.org> wrote:

>> On 27 janv. 2016, at 00:07, Dave Abrahams via swift-evolution
>> <swift-evolution at swift.org> wrote:
>> Does anybody on this list feel that "precondition" is too inaccessible?
> I don’t, but I do like “require”. Unlike “precondition”, “require” is
> straightforward language. 

...which is why I originally requested the change.

> That particular use of “precondition” isn’t necessarily
> “pre”-anything; nothing prevents anyone from sticking a precondition()
> call just before returning from a function; then it becomes a weird
> misnomer.

Sort of, sort of not.  It happens that sometimes you can't tell that the
precondition is violated until sometime late in the function.  So it may
be a surprising place to see the word "precondition," but it still can
be a precondition check.

> I am skeptical of “term of art” as a justification, because it is
> nearly a synonym of “jargon”, and that is not a good thing.

It *is* a synonym for "jargon," which is neither a good nor a bad thing.
Jargon exists for a reason: to allow us to communicate precisely about
topics in specialized domains.  Can you imagine where we'd be if doctors
couldn't use medical jargon to describe symptoms and procedures?


More information about the swift-evolution mailing list