[swift-evolution] access control
taras.zakharko at uzh.ch
Mon Jan 25 09:33:31 CST 2016
> On 25 Jan 2016, at 16:12, Ilya Belenkiy <ilya.belenkiy at gmail.com> wrote:
> I didn’t propose to remove or repurpose the existing “private” access modifier. Instead, I proposed an additional “local” modifier for real data encapsulation. I think that the current “private” modifier is misnamed. It would be much more concise to call it “file internal” or something similar, but it looks like it’s too late to change this now. Both “private” and “local” are useful. One doesn’t have to exclude the other.
Oh, then I apologise. I got the wrong impression and/or was inattentive. In principle, I see no issue with adding a new access modifier as you suggest. I don’t think that I personally will use it, but some people could find it useful.
More information about the swift-evolution