[swift-evolution] [swift-evolution-announce] [Review] SE-0023 API Design Guidelines

charles@charlesism.com charlesism.com at gmail.com
Sun Jan 24 19:49:01 CST 2016

> Exactly. It seems like this convention is a work-around for a language design deficiency. In the case of value types, there are indeed other solutions that could even allow the same name for functions to be used for both mutating and non-mutating. The key thing of importance is bringing that clarity to the call site.

This makes a lot of sense. I'm glad we're considering design. There's rules to remember either way, but I'd prefer to use the same method name for both mutating and copying. Messing around with English grammar is a "naming problem" and costs a programmer more mental effort. Look no further than online debates over the best conjugation of this or that Protocol name. 

More information about the swift-evolution mailing list