[swift-evolution] [Review] SE-0023 API Design Guidelines

Curt Clifton curt at omnigroup.com
Sun Jan 24 12:50:11 CST 2016

> On Jan 24, 2016, at 12:34 AM, Jacob Bandes-Storch via swift-evolution <swift-evolution at swift.org> wrote:
> I agree that "sinInPlace()", "meanInPlace()", "remainderInPlace()" seem to work pretty well, but I'm aware that I'm drawing on experience with the old names of sortInPlace(), subtractInPlace(), etc., and in fact this case is worse because the first words aren't really verbs (you can't sine something in place any more than you can sine it). "takeSine()" doesn't sound great either.

How about "applyingSine()" , "applyingMean()", and "applyingRemainder()"? 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160124/8238b406/attachment.html>

More information about the swift-evolution mailing list