[swift-evolution] [Review] SE-0005 Better Translation of Objective-C APIs Into Swift

Jacob Bandes-Storch jtbandes at gmail.com
Sat Jan 23 02:59:05 CST 2016


Proposal link:
https://github.com/apple/swift-evolution/blob/master/proposals/0005-objective-c-name-translation.md

> What is your evaluation of the proposal?

I would really appreciate seeing what *all* of the Foundation/Cocoa/Cocoa
Touch APIs would look like when imported using this scheme. If we're going
to bikeshed API translation, we should bikeshed all of it to avoid
inconsistency. (It may be that some issues aren't resolvable with the
simple rules proposed, and instead we should improve the API overlays.)

Some specific concerns:


     func *reversing()* -> UIBezierPath

I believe this would be better named *reversed()*.


    var *dateComponentUndefined*: Int { get }

It seems pretty weird to have a global/top-level constant that starts with
a lowercase letter, and whose first 2 subwords are describing its type.


    class func *darkGray*() -> UIColor

I would rather see this imported as `class var *DarkGray*: UIColor { get }`.


Otherwise, I'm okay with the proposed changes. I really like the "Add
Default Arguments" section. :-)


> Is the problem being addressed significant enough to warrant a change to
Swift?

Yes. The (current) majority of Swift users are writing software for Apple
platforms, so they interact constantly with Obj-C APIs such as these.


> How much effort did you put into your review? A glance, a quick reading,
or an in-depth study?

Fairly in-depth.

Jacob

On Fri, Jan 22, 2016 at 1:02 PM, Douglas Gregor via swift-evolution <
swift-evolution at swift.org> wrote:

> Hello Swift community,
>
> The review of SE-0005"Better Translation of Objective-C APIs Into Swift"
> begins now and runs through January 31, 2016. The proposal is available
> here:
>
>
> https://github.com/apple/swift-evolution/blob/master/proposals/0005-objective-c-name-translation.md
>
> Reviews are an important part of the Swift evolution process. All reviews
> should be sent to the swift-evolution mailing list at
>
> https://lists.swift.org/mailman/listinfo/swift-evolution
>
> or, if you would like to keep your feedback private, directly to the
> review manager. When replying, please try to keep the proposal link at the
> top of the message:
>
> Proposal link:
>
>
> https://github.com/apple/swift-evolution/blob/master/proposals/0005-objective-c-name-translation.md
>
> Reply text
>
> Other replies
>
> <https://github.com/apple/swift-evolution#what-goes-into-a-review-1>What
> goes into a review?
>
> The goal of the review process is to improve the proposal under review
> through constructive criticism and, eventually, determine the direction of
> Swift. When writing your review, here are some questions you might want to
> answer in your review:
>
>    - What is your evaluation of the proposal?
>    - Is the problem being addressed significant enough to warrant a
>    change to Swift?
>    - Does this proposal fit well with the feel and direction of Swift?
>    - If you have used other languages or libraries with a similar
>    feature, how do you feel that this proposal compares to those?
>    - How much effort did you put into your review? A glance, a quick
>    reading, or an in-depth study?
>
> More information about the Swift evolution process is available at
>
> https://github.com/apple/swift-evolution/blob/master/process.md
>
> Thank you,
>
> -Doug Gregor
>
> Review Manager
>
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160123/5b371a7b/attachment.html>


More information about the swift-evolution mailing list