[swift-evolution] Pre-proposal: CaseEnumerable protocol (derived collection of enum cases)
possen at gmail.com
Wed Jan 20 09:06:00 CST 2016
I was originally thinking T.allCases. When reading trough.
valueEnumerable could work trying to think something shorter and easier to read.
This is short and easy to understand and could be used in other contexts:
> On Jan 18, 2016, at 11:15 PM, Jacob Bandes-Storch via swift-evolution <swift-evolution at swift.org> wrote:
> OK, I can see the argument here. I was worried about making this proposal so broad that it wouldn't be seriously considered, but I agree that choosing more general names will open it up to future expansion.
> Here are some more name ideas:
> - CaseEnumerable (in the proposal draft)
> - T.cases (in the proposal draft)
> - T.allCases
> - FiniteType (as you suggested)
> - FiniteValueType
> - ValueEnumerable
> - T.values
> - T.allValues
> Thoughts? More suggestions? I think I like ValueEnumerable.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution