[swift-evolution] Thoughts on clarity of Double and Float type names?

davesweeris at mac.com davesweeris at mac.com
Thu Jan 7 22:05:41 CST 2016

My thoughts are that I wish they’d been named Float32 and Float64, and that “Float” was typealiased to the “native word size” floating point type, so that all the numeric types had the same naming scheme. But with Float/Double being around for, what, 1.5(?) years, I wouldn’t blame anyone for thinking it’s not worth the hassle to switch (although I would be in favor of it if there was an actual vote or something).

Also, it’d be nice to have built-in arbitrary precision types for us math nerds, but I’m well aware that’s a whole other thing.

> On Jan 4, 2016, at 12:58, Alex Johnson via swift-evolution <swift-evolution at swift.org> wrote:
> Hi all,
> I'm curious how other members of the Swift community feel about the clarity of the "Double" and "Float" type names. It seems incongruous that the default type for integers is "Int", but the default type for floating point numbers is not "Float".

More information about the swift-evolution mailing list