[swift-evolution] rename dropFirst() and dropLast()
david at alkaline-solutions.com
Wed Dec 30 00:23:44 CST 2015
I do rather like that, although the thread stalled a week ago which is equivalent to 1 swift-evolution year :-)
Is the current thinking that “$ + 3” and its ilk be a literal or computation returning some sort of Offset or Slice value, and SequenceType would define a subscript operation taking a Slice and returning an Element or SubSequence respectively?
> On Dec 29, 2015, at 5:53 PM, Dave Abrahams <dabrahams at apple.com> wrote:
>> On Dec 28, 2015, at 5:35 PM, David Waite via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
>> If one were to rename dropFirst/dropLast, I’d love for prefix and suffix to be renamed also to better pair with the methods.
> I prefer to address this by creating a unified EDSL for describing all of these operations as discussed in this thread: Re: Proposal: Python's indexing and slicing <http://news.gmane.org/find-root.php?message_id=ED492767%2dE1ED%2d41D6%2d90A8%2dBCA9AC6D0F34%40apple.com>
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution