[swift-evolution] rename dropFirst() and dropLast()
daniel at duan.org
Mon Dec 28 18:03:35 CST 2015
Indeed, the guideline clarifies! .excludingFirst() is better :)
> On Dec 28, 2015, at 3:53 PM, Michel Fortin <michel.fortin at michelf.ca> wrote:
> Le 28 déc. 2015 à 17:27, Daniel Duan via swift-evolution <swift-evolution at swift.org> a écrit :
>> .dropFirst() => .excludeFirst()
>> What do y’all think?
> Following the new API guidelines, shouldn't the name be either `droppingFirst` or `excludingFirst`? That would solve your problem, right? Many things still need to be adapted to the new conventions.
> Michel Fortin
More information about the swift-evolution