[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"
dabrahams at apple.com
Wed Dec 23 17:08:42 CST 2015
> On Dec 23, 2015, at 2:51 PM, Matt Whiteside via swift-evolution <swift-evolution at swift.org> wrote:
> Just want to put 2 other ideas out there for completeness:
My 2c: if we’re tack something onto “type”, the only appropriate modifier is “associated.” “Associated type” isn’t a term we invented; it’s the correct accepted technical term for the role these declarations play in generic programming.
>> On Dec 23, 2015, at 14:30, Douglas Gregor via swift-evolution <swift-evolution at swift.org> wrote:
>>> On Dec 23, 2015, at 1:53 PM, Michel Fortin via swift-evolution <swift-evolution at swift.org> wrote:
>> It’s not always inferred, though.
>> - Doug
>> swift-evolution mailing list
>> swift-evolution at swift.org
> swift-evolution mailing list
> swift-evolution at swift.org
More information about the swift-evolution