[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"
matthew at anandabits.com
Wed Dec 23 14:46:53 CST 2015
Sent from my iPhone
> On Dec 23, 2015, at 2:42 PM, James Campbell via swift-evolution <swift-evolution at swift.org> wrote:
> The thing is associated type means nothing to me, it's too technical. Placeholder type I think would be better even if it's only what we called it in the documentation
Programming languages are technical and it has a very clear meaning in Swift.
> Sent from my iPhone
>> On 23 Dec 2015, at 20:35, Chris Lattner via swift-evolution <swift-evolution at swift.org> wrote:
>>> On Dec 23, 2015, at 9:59 AM, Erica Sadun <erica at ericasadun.com> wrote:
>>> And what are your feelings about: typestandin, typeplaceholder, or adoptedtype? How would you describe the functionality of these members if you weren't looking for a keyword?
>> These don’t really speak to me, just because they aren’t the terminology that people use to refer to these. “standin” and “placeholder” are also pretty vacuous.
>> swift-evolution mailing list
>> swift-evolution at swift.org
> swift-evolution mailing list
> swift-evolution at swift.org
More information about the swift-evolution