[swift-evolution] Proposal: Enum 'count' functionality

Rob Mayoff mayoff at dqd.com
Wed Dec 23 02:12:35 CST 2015

On Tue, Dec 22, 2015 at 12:33 AM, Zef Houssney via swift-evolution <
swift-evolution at swift.org> wrote:

> I agree with Stephen Celis that the best names for this (yet) are
> definitely `cases` and optionally `rawValues` if the cases are
> RawRepresentable.

That makes me want to say `for case in SomeEnum.cases { ... }`, which is a
syntax error, as opposed to `for value in SomeEnum.values { ... }`, which
is legal.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20151223/c0a665e5/attachment.html>

More information about the swift-evolution mailing list