[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"

Paul Cantrell cantrell at pobox.com
Tue Dec 22 11:36:17 CST 2015

>> Unless typestandin, typeplaceholder, or adoptedtype are placed on the table, I don't really see any reason to introduce a keyword other than associatedtype for this proposal. 
> +1.  associatedtype seems better than any other option I’ve seen thus far (including the new ones you mentioned).

If the language construct is called an “associated type,” then introducing a keyword that uses any terminology other than “associated” is a recipe for eternal community confusion.

I could go for associatedtype, associated_type, or associated — but I agree that anything else, including typealias, seems inferior.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20151222/da2ea6c1/attachment.html>

More information about the swift-evolution mailing list