[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"

Michel Fortin michel.fortin at michelf.ca
Mon Dec 21 20:49:32 CST 2015

Le 21 déc. 2015 à 21:34, Dave Abrahams via swift-evolution <swift-evolution at swift.org> a écrit :

> I’m actually coming around to wanting it to be just “type” as a contextual keyword, if we can make that work.  The point is that these types aren’t “associated” in any way that distinguishes them from other requirements on nested declarations, i.e. funcs and vars.

Could also use `typename`. But maybe that's too easy to mix with `typealias`.

Michel Fortin
michel.fortin at michelf.ca

More information about the swift-evolution mailing list