[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"
loiclecrenier at icloud.com
Sun Dec 20 05:47:00 CST 2015
> Aren't we bikeshedding here? These are all good names; I think we can pick one, and leave the final choice to the core team.
Yes, we are :(
I was reluctant to start this thread, but I think it’s worse if the core team has this debate during the review.
I promise I’ll choose a keyword before the end of the week (and it will most likely be requiredtype)
> My personal preference is for something like “associated type X” or “associated typealias X” — no need for an underscore when you can require a space. Right now “typealias” is probably the word to use, although if Swift later introduces “type”, that would be a better choice. And I see “associated” as a context-specific modifier anyway; could even be spelled “@associated” (I'm still unclear about the rules about @/no-@).
More information about the swift-evolution