[swift-evolution-announce] [Accepted] SE-0158 Package Manager Manifest API Redesign

Rick Ballard rballard at apple.com
Fri Mar 17 00:57:19 CDT 2017

Proposal Link: https://github.com/apple/swift-evolution/blob/master/proposals/0158-package-manager-manifest-api-redesign.md

The review of SE-0158 "Package Manager Manifest API Redesign" ran from March 7 until March 15. The proposal is accepted with the following revisions:

– The "To" in "upToNextMajor" and "upToNextMinor" will be capitalized.
– "upToNextMajor()" and "upToNextMinor()" will name the first parameter "from:" for clarity.
– ".only" will be removed, as it was duplicative versus ".exact".
– We will have cases for ".branch" and ".revision" version specifiers, but will not provide special package initializers with named parameters for these.

This proposal was generally supported, though it did require some discussion and minor revision, and some users are eager for future proposals adding new API not covered by this proposal.

Thanks to everyone who participated!

- Rick Ballard

Review Manager

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution-announce/attachments/20170316/2097cd68/attachment.html>

More information about the swift-evolution-announce mailing list