[swift-dev] Renaming SILSuccessor -> SILCFGEdge
mgottesman at apple.com
Wed Apr 26 15:24:12 CDT 2017
I am currently doing some small fixes to SILSuccessor (adding some comments and fixing some issues exposed by LLVM upstream). As I read the code it became pretty apparent that the name is a misnomer... SILSuccessor is not just representing a successor, rather it is representing a whole CFG edge. This can be seen in how SILSuccessor is used to iterate over the predecessors of the block.
With that in mind, I would like to rename SILSuccessor to SILCFGEdge. It will make it much clearer without knowing any context what this data structure is used for.
Any objections, disagreements, flames, etc?
More information about the swift-dev