[swift-dev] Cross compilation for linux failed on Mac

Труб Илья itrub at yandex.ru
Thu Mar 17 14:31:52 CDT 2016

Dear colleagues,
It seems to me, something was happened with cross-compilation on MacOS. I have successfully built all libraries for 32-bit ARM architecture and then built applications and libraries on Ubuntu 15 with x86_64 Swift compiler, pointing out --target=armv7-unknown-linux-gnueabi and placing arm-libraries at convenient places.
Then I built from the same sources swift-compiler on Macintosh and tried to do the same, but swiftc wrote, that target armv7-unknown-linux-gnueabi (or arm-linux-gnueabi)
is unknown for it! I exactly remember, that two months ago cross-compilation on Mac worked with target=arm-linux-gnueabi, but now does not.
I continued experiments and found, that swiftc recognizes target=armv7-apple-macosx10.11
I pointed out this target and placed libraries and modules, but I received:

module file was created by a newer version of the compiler:    <path to arm Swift.swiftmodule>

I was wondered, because sources are absolutely the same.
Output of swiftc --version  on Mac:
Swift version 3.0-dev (LLVM 0d07a5d3d5, Clang 11493b0f62, Swift c6a0f51611)
Target: x86_64-apple-macosx10.9

Output of swiftc --version on ARM-emulator:
Swift version 3.0-dev (LLVM , Clang , Swift )
Target: armv7l-unknown-linux-gnueabi

How you can explain all these things? May be, cross-compilation on Mac is now prohibited for linux platforms? I can not imagine other reasons.
Thanks in advance for answer.

More information about the swift-dev mailing list