[swift-dev] Build failure? "LLVM ERROR: Cannot represent a subtraction with a weak symbol"

Brian Gesiak modocache at gmail.com
Thu Jan 28 11:44:49 CST 2016

Hello all!

I'm encountering a build failure when compiling the stdlib, using the tip
of master as of this morning (d44d6e). I'm running Ubuntu 15.10 on a x86_64

Here are my build logs:
https://gist.github.com/modocache/a85851a53b570d5fca47. The logs show that
I remove my build directory completely, before starting a clean build with
`utils/build-script -R`.

I was surprised to see a build failure, so I tried a bisect to narrow down
what may have caused it. Here's the log from the bisect, which I made
between master (d44d6e) and a known good commit (061c77):

The bisect points to commit 638e4b, "IRGen/Runtime: Use relative addresses
in nominal type descriptors". But I'm skeptical: that commit is weeks old,
and was even included in swift-DEVELOPMENT-SNAPSHOT-2016-01-25-a. I very
much doubt it introduced a build failure.

I tried building swift-DEVELOPMENT-SNAPSHOT-2016-01-25-a, and even *that*
doesn't build on my system!! I assume this snapshot has passed CI, so I
thought there must be something wrong with my system. But William Dillion
tells me he's experiencing the same error (

William and I are both working on armv7 ports, so perhaps both of our build
machines are similarly broken. But I'm curious if anyone has any ideas on
what the problem might be, or if this build error reproduces for anyone
else building on Linux. Thoughts?

- Brian Gesiak
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-dev/attachments/20160128/428e9c22/attachment.html>

More information about the swift-dev mailing list