[swift-corelibs-dev] Troubleshooting libdispatch build failure

David P Grove groved at us.ibm.com
Wed Jul 6 19:09:57 CDT 2016

ok, thanks for the details.

I'll grab the latest myself tomorrow morning and see if I can reproduce.


From:	Jean-Pierre Simard <jp at jpsim.com>
To:	David P Grove/Watson/IBM at IBMUS
Cc:	swift-corelibs-dev at swift.org
Date:	07/06/2016 06:21 PM
Subject:	Re: Troubleshooting libdispatch build failure

Thanks for getting back to me so quickly Dave.

This worked last week, but didn't yesterday when I tried again. My "last
few days" guess might actually just be since yesterday morning. Maybe
something's changed since your last checkouts from yesterday morning?
Running these commands on a fresh Ubuntu 16.04 machine (i.e. no build
cache) gives me the output I shared above.

apt-get update && \
    apt-get install -y \
      autoconf \
      clang \
      cmake \
      git \
      icu-devtools \
      libblocksruntime-dev \
      libbsd-dev \
      libedit-dev \
      libicu-dev \
      libkqueue-dev \
      libncurses5-dev \
      libpython-dev \
      libsqlite3-dev \
      libtool \
      libxml2-dev \
      ninja-build \
      pkg-config \
      python \
      swig \
git clone https://github.com/apple/swift.git
cd swift
utils/update-checkout --clone
utils/build-script --libdispatch

I suspect that the Xcode 8 beta 2 set of changes that landed yesterday may
have caused this. There were patches on all sorts of repos (swift-llvm,
swift-clang, swift, etc).

On Wed, Jul 6, 2016 at 4:52 PM, David P Grove <groved at us.ibm.com> wrote:

  There has been some churn over the last few days, but I am successfully
  using util/build-script to build libdispatch with the current tip of the
  master branch of libdispatch (and a swift checkout of the master branch
  from yesterday morning). Maybe updating the checkout of libdispatch would


  Inactive hide details for Jean-Pierre Simard ---07/06/2016 04:28:46
  PM---Up until a few days ago, running 'util/build-script --Jean-Pierre
  Simard ---07/06/2016 04:28:46 PM---Up until a few days ago, running
  'util/build-script --libdispatch' completed successfully.

  From: Jean-Pierre Simard <jp at jpsim.com>
  To: swift-corelibs-dev at swift.org
  Cc: David P Grove/Watson/IBM at IBMUS
  Date: 07/06/2016 04:28 PM
  Subject: Troubleshooting libdispatch build failure

  Up until a few days ago, running 'util/build-script --libdispatch'
  completed successfully.

  Now it fails, generating the following errors. Any ideas on how to
  resolve these? Or other ways people are using to build libdispatch at the
  moment? Thanks!

  /bin/bash ../libtool  --tag=CXX
  --mode=compile /build/Ninja-DebugAssert/llvm-linux-x86_64/bin/clang++
  -DHAVE_CONFIG_H -I. -I//swift-corelibs-libdispatch/src -I../config  -I..
  -I//swift-corelibs-libdispatch -I//swift-corelibs-libdispatch/private
  -DDISPATCH_USE_DTRACE=0 -I//swift-corelibs-libdispatch/libpwq/include
  -Wall -fvisibility=hidden -momit-leaf-frame-pointer
  -I/usr/include/kqueue -isystem /usr/include/bsd -DLIBBSD_OVERLAY -fblocks
  -std=gnu++11 -fno-exceptions -g -O2 -c -o
  swift/libdispatch_la-DispatchStubs.lo `test -f 'swift/DispatchStubs.cc'
  || echo '//swift-corelibs-libdispatch/src/'`swift/DispatchStubs.cc
  libtool: compile:  /build/Ninja-DebugAssert/llvm-linux-x86_64/bin/clang++
  -DHAVE_CONFIG_H -I. -I//swift-corelibs-libdispatch/src -I../config -I..
  -I//swift-corelibs-libdispatch -I//swift-corelibs-libdispatch/private
  -DDISPATCH_USE_DTRACE=0 -I//swift-corelibs-libdispatch/libpwq/include
  -Wall -fvisibility=hidden -momit-leaf-frame-pointer -I/usr/include/kqueue
  -isystem /usr/include/bsd -DLIBBSD_OVERLAY -fblocks -std=gnu++11
  -fno-exceptions -g -O2
  -c //swift-corelibs-libdispatch/src/swift/DispatchStubs.cc  -fPIC -DPIC
  -o swift/.libs/libdispatch_la-DispatchStubs.o
  /build/Ninja-DebugAssert/swift-linux-x86_64/bin/swiftc -frontend
  -c //swift-corelibs-libdispatch/src/swift/Block.swift //swift-corelibs-libdispatch/src/swift/Data.swift //swift-corelibs-libdispatch/src/swift/Dispatch.swift //swift-corelibs-libdispatch/src/swift/IO.swift //swift-corelibs-libdispatch/src/swift/Private.swift //swift-corelibs-libdispatch/src/swift/Queue.swift //swift-corelibs-libdispatch/src/swift/Source.swift //swift-corelibs-libdispatch/src/swift/Time.swift //swift-corelibs-libdispatch/src/swift/Wrapper.swift
 -primary-file //swift-corelibs-libdispatch/src/swift/Block.swift \
  -I//swift-corelibs-libdispatch -Xcc -fblocks -module-name Dispatch
  -module-link-name dispatch \
  -o /build/Ninja-DebugAssert/libdispatch-linux-x86_64/src/swift/Block.o
  -emit-module-path /build/Ninja-DebugAssert/libdispatch-linux-x86_64/src/swift/Block.o.~partial.swiftmodule
  -emit-module-doc-path /build/Ninja-DebugAssert/libdispatch-linux-x86_64/src/swift/Block.o.~partial.swiftdoc
 -emit-dependencies-path /build/Ninja-DebugAssert/libdispatch-linux-x86_64/src/swift/Block.o.d
  -emit-reference-dependencies-path /build/Ninja-DebugAssert/libdispatch-linux-x86_64/src/swift/Block.o.swiftdeps
  -module-cache-path ..
  <module-includes>:1:10: note: in file included from <module-includes>:1:
  #include "dispatch.h"
  //swift-corelibs-libdispatch/dispatch/dispatch.h:99:10: error:
  'os/object.h' file not found
  #include <os/object.h>
  //swift-corelibs-libdispatch/src/swift/Block.swift:13:8: error: could not
  build Objective-C module 'CDispatch'
  import CDispatch
  Makefile:956: recipe for target

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-corelibs-dev/attachments/20160706/f618ab1b/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: graycol.gif
Type: image/gif
Size: 105 bytes
Desc: not available
URL: <https://lists.swift.org/pipermail/swift-corelibs-dev/attachments/20160706/f618ab1b/attachment.gif>

More information about the swift-corelibs-dev mailing list