[swift-build-dev] [swift-evolution] [Review] SE-0158 Package Manager Manifest API Redesign
david at hartbit.com
Tue Mar 14 02:28:53 CDT 2017
Yep, after does sound confusing. I prefer from.
> On 14 Mar 2017, at 08:22, Ankit Aggarwal via swift-evolution <swift-evolution at swift.org> wrote:
>> – Dave Sweeris' point about this reading wrong in English as .upToNextMajor("x.y.z") (vs. of "x.y.z".upToNextMajor) makes sense to us too. As a result, we're going to clarify this by changing it to .upToNextMajor(after:"x.y.z") and .upToNextMinor(after:"x.y.z").
> The "after" in .upToNextMajor(after: "x.y.z") sounds like we're going to pick the version after `x.y.z`, for e.g. `x.y.(z+1)`, and go upto the next major version. I think we should use `from` instead of `after`, which is more clear IMO. It also feels like `after` and `from` (in shorthand) do different things, and if we use `form`, it will also be reasonable to assume that the `.package(url:from:)` is a shorthand form.
> - Ankit
> swift-evolution mailing list
> swift-evolution at swift.org
More information about the swift-build-dev