[swift-build-dev] [swift-evolution] Proposal: Package Manager Version Pinning

Ryan Lovelett swift-dev at ryan.lovelett.me
Fri Oct 14 14:04:13 CDT 2016

> Whether "pinning" is the right word is a different debate, but when we
> view pinning as a workflow-focused feature, versus the specification
> in the manifest (which is the "requirement"), then I think the
> connotation actually works fairly well (e.g., a pinboard is something
> you pin to while working, or pinning a dress while you stitch it). I
> also wasn't a huge fan of pin initially, but as it bounced around in
> my head for a while I really started to like it, for exactly this
> connotation reason.

I think this comment drives at the core of the difference between this
proposal and what Orta, Alexis and others are saying. (At least for me)

The description you've provided here, specifically the word "workflow",
and the concept of operations described by the proprosal are meant to be
a transient. They are meant as a temporary description of how these
dependencies should be kept in order.  To my mind one "puts a pin" in
something temporarily. To comeback to it later to do something with it
at that time. Thus the pin probably does work with this concept.

Conversely, the concept of "locking" something feels less transient. It
feels more permanent. More like the concept of operations described by
Orta, Alexis and others. Idle speculation: might be why those other
managers selected the word lock.

Not sure where I come down on the whole thing yet. Just wanted to say
that if the propsal goes another way than what was first propsed  a new
word likely should be investigated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-build-dev/attachments/20161014/6348d48a/attachment.html>

More information about the swift-build-dev mailing list