[swift-build-dev] More layering changes...

Anders Bertelrud anders at apple.com
Wed May 18 11:01:05 CDT 2016

On 2016-05-17, at 17.26, Daniel Dunbar via swift-build-dev <swift-build-dev at swift.org> wrote:

> PackageModel (renamed from PackageType):
> - This defines the basic model objects for Packages. The rename is to try and convey the intent more clearly. This module is intended to define "pure" model objects.

Just to clarify what we mean by “pure” here — there should be no conventions or other magic applied at this level, and no intermixed resolution policies etc.  That’s added by higher levels.  Also, at this level there are no connection between packages — that happens in PackageGraph.


More information about the swift-build-dev mailing list